
<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, 
	minimum-scale=1.0, maximum-scale=1.0">
<meta name="viewport" content="width=device-width, user-scalable=no">

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<title>Jeremy Zucker delivers energetic, feel-good performance in summer heat &middot; The Badger Herald</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://badgerherald.com/wordpress/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://badgerherald.com/wordpress/wp-content/themes/exa/js/html5.js" type="text/javascript"></script>
	<![endif]-->

<meta name="news_keywords" content="beach island, electronica, glisten, jeremy zucker, music, republic records, summerfest, summerfest 2018, madison, wisconsin, university of wisconsin, badgers" />
<meta name="original-source" content="https://badgerherald.com/artsetc/2018/07/11/jeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat/" />
<link rel="canonical" href="https://badgerherald.com/artsetc/2018/07/11/jeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat/" />
<link rel="publisher" href="http://plus.google.com/+BadgerHerald1969" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/badgerherald.com\/","name":"The Badger Herald","potentialAction":{"@type":"SearchAction","target":"https:\/\/badgerherald.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/badgerherald.com\/artsetc\/2018\/07\/11\/jeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat\/","sameAs":["https:\/\/facebook.com\/badgerherald","http:\/\/instagram.com\/badgerherald","http:\/\/plus.google.com\/+BadgerHerald1969","https:\/\/twitter.com\/badgerherald"],"@id":"#organization","name":"The Badger Herald","logo":""}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Badger Herald &raquo; Feed" href="https://badgerherald.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Badger Herald &raquo; Comments Feed" href="https://badgerherald.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Badger Herald &raquo; Jeremy Zucker delivers energetic, feel-good performance in summer heat Comments Feed" href="https://badgerherald.com/artsetc/2018/07/11/jeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/badgerherald.com\/wordpress\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.7"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='exa-style-css' href='https://badgerherald.com/wordpress/wp-content/themes/exa/style.css?ver=1506896295' type='text/css' media='all' />
<link rel='stylesheet' id='hexa-style-css' href='https://badgerherald.com/wordpress/wp-content/themes/hexa/style.css?ver=1491267898' type='text/css' media='all' />
<link rel='stylesheet' id='exa-icons-css' href='https://badgerherald.com/wordpress/wp-content/themes/exa/assets/css/fontastic/styles.css?v=12&#038;ver=4.8.7' type='text/css' media='all' />
<link rel='stylesheet' id='exa-fonts-css' href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C700%2C400italic%2C700italic%7CPT+Sans+Narrow%3A400%2C700&#038;ver=4.8.7' type='text/css' media='all' />
<link rel='stylesheet' id='exa_inline_link_style-css' href='https://badgerherald.com/wordpress/wp-content/themes/exa/assets/css/inline.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://badgerherald.com/wordpress/wp-content/plugins/jetpack/css/jetpack.css?ver=5.3' type='text/css' media='all' />
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var exa_inline_click = {"ajaxurl":"https:\/\/badgerherald.com\/wordpress\/wp-admin\/admin-ajax.php","id":"233238","nonce":"dcdd1499cd"};
/* ]]> */
</script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-content/themes/exa/js/count-clicks.js?ver=4.8.7'></script>
<link rel='https://api.w.org/' href='https://badgerherald.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://badgerherald.com/wordpress/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://badgerherald.com/wordpress/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.8.7" />
<link rel='shortlink' href='https://badgerherald.com/?p=233238' />
<link rel="alternate" type="application/json+oembed" href="https://badgerherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbadgerherald.com%2Fartsetc%2F2018%2F07%2F11%2Fjeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://badgerherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbadgerherald.com%2Fartsetc%2F2018%2F07%2F11%2Fjeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>

<meta property='og:title' content='Jeremy Zucker delivers energetic, feel-good performance in summer heat' />
<meta property="og:description" content="The young songwriter continues his upward trend" />
<meta property='og:site_name' content='The Badger Herald' />
<meta property='og:type' content='article' />
<meta property='og:article:published_time' content='2018-07-11T13:41:02-0500' />
<meta property='og:article:modified_time' content='2018-07-11T13:41:02-0500' />
<meta property='og:article:section' content='ArtsEtc' />
<meta property='og:url' content='https://badgerherald.com/artsetc/2018/07/11/jeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat/' />
<meta property='og:image' content='https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0283.png' />

<meta name='twitter:card' content='summary_large_image' />
<meta name='twitter:image:src' content='https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0283.png' />
<meta name='twitter:title' content='Jeremy Zucker delivers energetic, feel-good performance in summer heat' />
<meta name="twitter:description" content="The young songwriter continues his upward trend" />
<meta name='twitter:site' content='@badgerherald' />
<link rel='icon' href='https://badgerherald.com/wordpress/wp-content/themes/exa/assets/img/favicons/favicon.ico' type='image/x-icon' /> <style type="text/css" id="wp-custom-css">
			.menuNews{
	//background: red;
}		</style>
</head>
<body class="post-template-default single single-post postid-233238 single-format-standard">
<div id="page">
<div class="container preflight    flex">
<div class="ad preflight-ad wrapper">
<div class='dfw-unit' data-adunit='badgerherald.com-preflight' data-size-mapping='mapping1'></div>
</div>
<div class="scroll-view">
Scroll to Dismiss
</div>
</div>
<div class="container nameplate  grey  flex">
<div class="wrapper">
<a class="logo" href="https://badgerherald.com">
<img src="https://badgerherald.com/wordpress/wp-content/themes/exa/assets/img/logo/header-horizontal.png" />
</a>
<a class="menus-button">Menu</a>
<div class="menus">
<div class="mobile-right">
<ul id="menu-sections" class="menu main-menu"><li id="menu-item-123779" class="menuNews menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-123779"><a href="https://badgerherald.com/./news/">News</a>
<ul class="sub-menu">
<li id="menu-item-208525" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208525"><a href="https://badgerherald.com/topic/campus/">UW-Madison Campus</a></li>
<li id="menu-item-208358" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208358"><a href="https://badgerherald.com/topic/madison/">City of Madison</a></li>
<li id="menu-item-208526" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208526"><a href="https://badgerherald.com/topic/wisconsin/">State of Wisconsin</a></li>
</ul>
</li>
<li id="menu-item-207544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-207544"><a href="https://badgerherald.com/./features/">Features</a></li>
<li id="menu-item-123780" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-123780"><a href="https://badgerherald.com/./sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-208528" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208528"><a href="https://badgerherald.com/topic/football/">Football</a></li>
<li id="menu-item-208529" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208529"><a href="https://badgerherald.com/topic/mens-basketball/">Men&#8217;s Basketball</a></li>
<li id="menu-item-208532" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208532"><a href="https://badgerherald.com/topic/womens-basketball/">Women&#8217;s Basketball</a></li>
<li id="menu-item-208530" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208530"><a href="https://badgerherald.com/topic/mens-hockey/">Men&#8217;s Hockey</a></li>
<li id="menu-item-208531" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208531"><a href="https://badgerherald.com/topic/womens-hockey/">Women&#8217;s Hockey</a></li>
<li id="menu-item-208533" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208533"><a href="https://badgerherald.com/topic/volleyball/">Volleyball</a></li>
<li id="menu-item-208535" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208535"><a href="https://badgerherald.com/topic/softball/">Softball</a></li>
<li id="menu-item-208539" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208539"><a href="https://badgerherald.com/topic/baseball/">Baseball</a></li>
<li id="menu-item-208534" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208534"><a href="https://badgerherald.com/topic/mens-soccer/">Men&#8217;s Soccer</a></li>
<li id="menu-item-208536" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208536"><a href="https://badgerherald.com/topic/womens-soccer/">Women&#8217;s Soccer</a></li>
<li id="menu-item-208537" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208537"><a href="https://badgerherald.com/topic/mens-tennis/">Men&#8217;s Tennis</a></li>
<li id="menu-item-208538" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208538"><a href="https://badgerherald.com/topic/womens-tennis/">Women&#8217;s Tennis</a></li>
</ul>
</li>
<li id="menu-item-123781" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-123781"><a href="https://badgerherald.com/./opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-208541" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208541"><a href="https://badgerherald.com/topic/column/">Column</a></li>
<li id="menu-item-208542" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208542"><a href="https://badgerherald.com/topic/letter-to-the-editor/">Letter to the Editor</a></li>
<li id="menu-item-208566" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208566"><a href="https://badgerherald.com/topic/point-counterpoint/">Point-counterpoint</a></li>
</ul>
</li>
<li id="menu-item-123782" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-123782"><a href="https://badgerherald.com/./artsetc/">ArtsEtc</a>
<ul class="sub-menu">
<li id="menu-item-208573" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208573"><a href="https://badgerherald.com/topic/art/">Art</a></li>
<li id="menu-item-208570" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208570"><a href="https://badgerherald.com/topic/music/">Music</a></li>
<li id="menu-item-208571" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208571"><a href="https://badgerherald.com/topic/film/">Film</a></li>
<li id="menu-item-208574" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208574"><a href="https://badgerherald.com/topic/food/">Food</a></li>
<li id="menu-item-208572" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208572"><a href="https://badgerherald.com/topic/hump-day/">Hump Day</a></li>
<li id="menu-item-208575" class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208575"><a href="https://badgerherald.com/topic/madtown-crier/">Madtown Crier</a></li>
</ul>
</li>
<li id="menu-item-170691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170691"><a href="http://badgerherald.com/topic/visuals">Visuals</a></li>
<li id="menu-item-170087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170087"><a href="https://badgerherald.com/./banter/">Banter</a></li>
</ul> <ul id="menu-social-media" class="menu social-menu"><li id="menu-item-208520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208520"><a href="http://facebook.com/badgerherald" class="facebook"><span class="hide">Facebook</span></a></li>
<li id="menu-item-208521" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208521"><a href="http://twitter.com/badgerherald" class="twitter"><span class="hide">Twitter</span></a></li>
<li id="menu-item-208522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208522"><a href="http://instagram.com/badgerherald" class="instagram"><span class="hide">Instagram</span></a></li>
</ul> </div>
<ul id="menu-about" class="menu secondary-menu"><li id="menu-item-170693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170693"><a href="https://badgerherald.com/about/">About</a></li>
<li id="menu-item-225106" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225106"><a href="https://badgerherald.com/masthead/spring-2018/">Staff</a></li>
<li id="menu-item-190879" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-190879"><a href="http://advertise.badgerherald.com/">Advertise</a></li>
<li id="menu-item-170692" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170692"><a href="https://badgerherald.com/newsletter/">Newsletter</a></li>
<li id="menu-item-222583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222583"><a href="https://projects.propublica.org/graphics/hatecrimes-form">Report Bias/Hate</a></li>
<li id="menu-item-203615" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-203615"><a href="https://badgerherald.com/job-board/">Job Search</a></li>
<li id="menu-item-191620" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191620"><a href="https://badgerherald.com/donate/">Donate</a></li>
</ul>
<div class="clearfix"></div>
<form class="search" action="/" method="get">
<input type="text" name="s" placeholder="Search..." value=""></input>
<input type="submit" value="Submit"></input>
</form>
</div>
</div>
</div>
<article id="post-233238" class="post-233238 post type-post status-publish format-standard has-post-thumbnail hentry category-artsetc tag-beach-island tag-electronica tag-glisten tag-jeremy-zucker tag-music tag-republic-records tag-summerfest tag-summerfest-2018">
<header class="container headline    ">
<div class="wrapper">
<ul class="topics">
<li>
<a href="https://badgerherald.com/./artsetc/" class="section">
Artsetc </a>
</li>
<li><span>Herald</span></li>
</ul>
<div class="clearfix"></div>
<h1 class="title">Jeremy Zucker delivers energetic, feel-good performance in summer heat</h1>
<h2 class="subhead">The young songwriter continues his upward trend</h2>
</div>
</header>
<div class="container content-two-column    article-display standard">
<div class="wrapper">
<main class="article-content">
<div class="meta">
<div class="mug-box">
<img src='https://badgerherald.com/wordpress/wp-content/uploads/2017/09/DSC_0435-2-345x225.jpg' classes='mug ' /> </div>
<span class="byline">
by <a class="author-link" href="https://badgerherald.com/author/jfrodl" title="Jeremy Frodl's Profile">
Jeremy Frodl </a>
</span> &middot; <span class="meta-time">Jul 11, 2018</span>
<a class="facebook-button" target="_blank" href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbadgerherald.com%2Fartsetc%2F2018%2F07%2F11%2Fjeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat%2F">Share</a>
<a class="tweet-button" target="_blank" href="https://twitter.com/intent/tweet?text=Jeremy+Zucker+delivers+energetic%2C+feel-good+performance+in+summer+heat&url=https%3A%2F%2Fbadgerherald.com%2Fartsetc%2F2018%2F07%2F11%2Fjeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat%2F&via=badgerherald&related=badgerherald">Tweet</a>
</div>
<div class="hero">
<img width="1374" height="916" src="https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0283.png" class="wp-image-233243 attachment-image-post-size size-image-post-size wp-post-image" alt="" /> <p class='hero-caption'><span class="hrld-media-credit"><span class="hrld-media-credit-name"><a href="https://badgerherald.com/author/jfrodl">Jeremy Frodl</a></span><span class="hrld-media-credit-org">/The Badger Herald</span></span></p>
<div class="clearfix"></div>
</div>
<section class="article-text">
<p>With the swagger, good looks and frosted tips of a nineties boyband member, 21-year-old Jeremy Zucker took to the Miller Lite Oasis stage on Thursday night. Coming out of 2017, he signed for major label Republic Records, it was an earned confidence, one of an up-and-coming star.</p>
<div id="attachment_233239" style="width: 658px" class="wp-caption alignnone"><img class="size-large wp-image-233239" src="https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0226-648x432.png" alt="" width="648" height="432" /><p class="wp-caption-text">Zucker introduces himself<br /><span class="hrld-media-credit"><span class="hrld-media-credit-name"><a href="https://badgerherald.com/author/jfrodl">Jeremy Frodl</a></span><span class="hrld-media-credit-org">/The Badger Herald</span></span></p><div class='ad ad-in-content' style='display:none;'><div class='dfw-unit' data-adunit='badgerherald.com-upper-sidekick' data-size-mapping='mapping2'></div></div></div>
<p>Since his first EP <em>Beach Island</em> was released in 2015, he had slowly built up an extremely loyal fanbase with his unique sound, an interesting mix of Jon Bellion-esque upbeat electronica and the introspection of Twenty-One Pilots or Bon Iver. It was because of this that he had built up an unusually large crowd for a non-headliner come time for performance.</p>
<div id="attachment_233240" style="width: 658px" class="wp-caption alignnone none"><img class="alignnone size-large wp-image-233240" src="https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0247-648x432.png" alt="" width="648" height="432" /><p class="wp-caption-text"><span class="hrld-media-credit"><span class="hrld-media-credit-name"><a href="https://badgerherald.com/author/jfrodl">Jeremy Frodl</a></span><span class="hrld-media-credit-org">/The Badger Herald</span></span></p></div>
<p>For artists that greatly rely on post-production effects (auto-tune, vocal layering, sound editing etc.) in their work, live shows pose an interesting challenge. Lacking a great deal of the technology that would be afforded to them in-studio, many performers can feel flat once they play live. This was not the case for Zucker.</p>
<p>Throughout the show, the talented musician controlled the sound with a polyphonic multi-dimensional controller (PMC), essentially a high-tech touch-based keyboard that can read the user&#8217;s finger movements to not only play notes but change a given note’s pitch and timbre in real time. With this, he was able to perform his own brand of electronica live, with excellent sound quality. Along with his natural talent and a healthy dose of easy-going charisma, Zucker more than compensated for the lack of studio production.</p><div class='ad ad-in-content' style="display:none;"><div class='dfw-unit' data-adunit='badgerherald.com-lower-sidekick' data-size-mapping='mapping3'></div></div>
<div id="attachment_233246" style="width: 658px" class="wp-caption alignnone"><img class="size-large wp-image-233246" src="https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0229brtter-648x432.png" alt="" width="648" height="432" /><p class="wp-caption-text">The nature of the PMC requires precise hand movements from the artist<br /><span class="hrld-media-credit"><span class="hrld-media-credit-name"><a href="https://badgerherald.com/author/jfrodl">Jeremy Frodl</a></span><span class="hrld-media-credit-org">/The Badger Herald</span></span></p></div>
<p>Beginning his set with the upbeat and carefree “Wildfire” off of his most recent EP <em>Glisten</em>, Zucker quickly got the crowd off their feet and dancing despite the day&#8217;s punishing heat, which he joined in with on the rare occasions he was away from his keyboard.</p>
<p>After manning the PMC for his hit “Keep my Head afloat” and several other songs, he switched over to the guitar which, despite initial technical difficulties, he played with the same fluency as his keyboard. This impressively displayed his participation in all parts of his music, befitting his status as a solo artist.</p>
<div id="attachment_233244" style="width: 658px" class="wp-caption alignnone none"><img class="alignnone size-large wp-image-233244" src="https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0253-648x432.png" alt="" width="648" height="432" /><p class="wp-caption-text"><span class="hrld-media-credit"><span class="hrld-media-credit-name"><a href="https://badgerherald.com/author/jfrodl">Jeremy Frodl</a></span><span class="hrld-media-credit-org">/The Badger Herald</span></span></p></div>
<p>Putting the guitar aside, he paused between songs and took a break from his laid-back stage persona, telling the audience “This next song is about a difficult topic, one that has affected me personally. Mental health.” He recalled times he had struggled with his own mental illness, depression, and told the crowd that a conversation about mental health was “a hard but necessary one.” He followed this up with one of his new singles, the bluntly named “All the Kids are Depressed.”</p>
<div id="attachment_233245" style="width: 658px" class="wp-caption alignnone"><img class="size-large wp-image-233245" src="https://badgerherald.com/wordpress/wp-content/uploads/2018/07/IMG_0244-648x432.png" alt="" width="648" height="432" /><p class="wp-caption-text">Zucker addresses the crowd<br /><span class="hrld-media-credit"><span class="hrld-media-credit-name"><a href="https://badgerherald.com/author/jfrodl">Jeremy Frodl</a></span><span class="hrld-media-credit-org">/The Badger Herald</span></span></p></div>
<p>As he moved towards the end of his set, he broke out his biggest hit, “Heavy,” which had been sampled by fellow artist Black Bear. As he took his leave, the catchy tune left a ringing in the audience’s head, closing one of Summerfest’s better ground acts.</p>
</section>
</main>
<aside class="sidebar">
<div class="ad sidebar-thing">
<div class='dfw-unit' data-adunit='badgerherald.com-upper-sidekick' data-size-mapping='mapping4'></div> </div>
<div class='popular-posts sidebar-thing'><div class="widget widget_analytic-bridge-popular-posts"><h2 class="widgettitle">Popular Posts</h2><ul class="count-8"><li class="post-214890 post type-post status-publish format-standard has-post-thumbnail hentry category-news topic-campus importance-featured"><h5><a href="https://badgerherald.com/news/2017/10/09/chemistry-teaching-assistant-with-history-of-anti-semitic-racist-behavior-removed-from-position-after-campus-backlash/">Chemistry teaching assistant with history of anti-Semitic, racist behavior removed from position after campus backlash</a></h5></li><li class="post-215100 post type-post status-publish format-standard has-post-thumbnail hentry category-news topic-campus importance-breaking"><h5><a href="https://badgerherald.com/news/2017/10/10/arrest-made-in-connection-with-assault-attempted-abduction-of-uw-student/">Arrest made in connection with assault, attempted abduction of UW student</a></h5></li><li class="post-215097 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-campus-carry tag-katie-pavlich tag-young-americans-for-freedom topic-campus importance-cover"><h5><a href="https://badgerherald.com/news/2017/10/10/katie-pavlich-discusses-campus-carry-amid-colorful-protests/">Katie Pavlich discusses campus carry amid colorful protests</a></h5></li><li class="post-214928 post type-post status-publish format-standard has-post-thumbnail hentry category-features topic-campus importance-cover"><h5><a href="https://badgerherald.com/features/2017/10/11/greek-life-feature/">Night and Day: As Greek life works to serve community, counter-culture of drinking, sexual assault pervades</a></h5></li><li class="post-214940 post type-post status-publish format-standard has-post-thumbnail hentry category-news topic-campus importance-featured"><h5><a href="https://badgerherald.com/news/2017/10/09/dejope-sacred-fire-circle-vandalized-in-intentional-despicable-act/">Dejope sacred fire circle vandalized in &#8216;intentional, despicable act&#8217;</a></h5></li><li class="post-214668 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion tag-first-amendment tag-free-speech tag-wisconsin topic-letter-to-the-editor"><h5><a href="https://badgerherald.com/opinion/2017/10/10/letter-to-the-editor-uw-system-more-tolerant-of-hate-than-those-who-stand-against-it/">Letter to the Editor: UW System more tolerant of hate than those who stand against it</a></h5></li><li class="post-215011 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion tag-communication tag-threats tag-uw-security topic-column"><h5><a href="https://badgerherald.com/opinion/2017/10/10/university-delay-in-threat-notification-puts-students-in-harms-way/">University delay in threat notification puts students in harms way</a></h5></li><li class="post-214408 post type-post status-publish format-standard has-post-thumbnail hentry category-news topic-madison"><h5><a href="https://badgerherald.com/news/2017/10/05/uw-student-punches-suspect-to-recover-wallet-asks-officer-for-note-to-avoid-test-next-morning/">UW student punches suspect to recover wallet, asks officer for note to avoid test next morning</a></h5></li></ul></div></div>
<div class="ad sidebar-thing">
<div class='dfw-unit' data-adunit='badgerherald.com-lower-sidekick' data-size-mapping='mapping5'></div> </div>
</aside>
<div class="clearfix"></div>
</div>
</div>
</article>
<div class="container footnotes   ">
<div class="wrapper">
<div class="meta">
<a class="facebook-button" target="_blank" href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbadgerherald.com%2Fartsetc%2F2018%2F07%2F11%2Fjeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat%2F">Share</a>
<a class="tweet-button" target="_blank" href="https://twitter.com/intent/tweet?text=Jeremy+Zucker+delivers+energetic%2C+feel-good+performance+in+summer+heat&url=https%3A%2F%2Fbadgerherald.com%2Fartsetc%2F2018%2F07%2F11%2Fjeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat%2F&via=badgerherald&related=badgerherald">Tweet</a>

<input class="share-url" type="text" onclick="this.select()" value="https://badgerherald.com/?p=233238" />
<hr />
<div class="fine-print">
<p>This article was published Jul 11, 2018 at 1:41 pm and last updated Jul 11, 2018 at 1:41 pm<p>
</div>
<div class="post-tags">
<span>Tags: </span>
<a target="_blank" href="https://badgerherald.com/tag/beach-island/">Beach island</a>,
<a target="_blank" href="https://badgerherald.com/tag/electronica/">Electronica</a>,
<a target="_blank" href="https://badgerherald.com/tag/glisten/">Glisten</a>,
<a target="_blank" href="https://badgerherald.com/tag/jeremy-zucker/">Jeremy Zucker</a>,
<a target="_blank" href="https://badgerherald.com/tag/music/">Music</a>,
<a target="_blank" href="https://badgerherald.com/tag/republic-records/">Republic records</a>,
<a target="_blank" href="https://badgerherald.com/tag/summerfest/">Summerfest</a>,
<a target="_blank" href="https://badgerherald.com/tag/summerfest-2018/">Summerfest 2018</a>
</div>
<a class="comment-button" href="#">Comments</a>
<aside class="comments" style="display:none">
<div id="disqus_thread">
</div>
</aside>
</div>
<div class="tall-ad">
<div class='dfw-unit' data-adunit='badgerherald.com-footnote-sidekick' data-size-mapping='mapping6'></div> </div>
<div class="more">
<h1>Next in <a href="https://badgerherald.com/./artsetc/" class="section">Artsetc</a></h1>
<ul>
<li><a href="https://badgerherald.com/artsetc/2018/05/04/hurts-donut-company-fills-void-of-delicious-donuts-on-state-street/" class="story">
<img width="860" height="470" src="https://badgerherald.com/wordpress/wp-content/uploads/2018/05/hurts-donuts-860x470.jpg" class="wp-image-232571 attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />
<h2 class="headline">Hurts Donut Company fills void of delicious donuts on State Street</h2>
<h3 class="subhead">Missouri-based baked goods to brighten anyone's morning with creative, delicious flavors, toppings</h3>
</a></li>
<li><a href="https://badgerherald.com/artsetc/2018/05/03/gr8-unknowns-artists-to-look-for-this-summer/" class="story">
<h2 class="headline">Gr8 Unknowns: Artists to look for this summer</h2>
<h3 class="subhead">Tracks, videos chosen from artists such as Foxy, Attaboy, Tyler the Creator to expand music taste</h3>
</a></li>
<li><a href="https://badgerherald.com/artsetc/2017/10/10/anais-mitchell-discusses-intense-connection-with-music-upcoming-show-in-madison/" class="story">
<h2 class="headline">Anaïs Mitchell discusses intense connection with music, upcoming show in Madison</h2>
<h3 class="subhead">Indie rock star reveals her humble beginnings, future goals</h3>
</a></li>
<li><a href="https://badgerherald.com/artsetc/2017/09/06/hitlist-first-day-of-school-jams/" class="story">
<h2 class="headline">Hitlist: First day of school jams</h2>
<h3 class="subhead">For those of us who wanted to just crawl back into bed this morning</h3>
</a></li>
</ul>
</div>
<div class="clearfix"></div>
</div>
</div>
<div class="container colophon   ">
<div class="wrapper">
<div class="left-rail rail">
<img class="logo" src="https://badgerherald.com/wordpress/wp-content/themes/exa/assets/img/logo/header-horizontal-white.png" />
</div>
<div class="middle-rail rail">
<div class="menu-sections-container"><ul id="menu-sections-1" class="menu"><li class="menuNews menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-123779"><a href="https://badgerherald.com/./news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208525"><a href="https://badgerherald.com/topic/campus/">UW-Madison Campus</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208358"><a href="https://badgerherald.com/topic/madison/">City of Madison</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208526"><a href="https://badgerherald.com/topic/wisconsin/">State of Wisconsin</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-207544"><a href="https://badgerherald.com/./features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-123780"><a href="https://badgerherald.com/./sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208528"><a href="https://badgerherald.com/topic/football/">Football</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208529"><a href="https://badgerherald.com/topic/mens-basketball/">Men&#8217;s Basketball</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208532"><a href="https://badgerherald.com/topic/womens-basketball/">Women&#8217;s Basketball</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208530"><a href="https://badgerherald.com/topic/mens-hockey/">Men&#8217;s Hockey</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208531"><a href="https://badgerherald.com/topic/womens-hockey/">Women&#8217;s Hockey</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208533"><a href="https://badgerherald.com/topic/volleyball/">Volleyball</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208535"><a href="https://badgerherald.com/topic/softball/">Softball</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208539"><a href="https://badgerherald.com/topic/baseball/">Baseball</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208534"><a href="https://badgerherald.com/topic/mens-soccer/">Men&#8217;s Soccer</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208536"><a href="https://badgerherald.com/topic/womens-soccer/">Women&#8217;s Soccer</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208537"><a href="https://badgerherald.com/topic/mens-tennis/">Men&#8217;s Tennis</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208538"><a href="https://badgerherald.com/topic/womens-tennis/">Women&#8217;s Tennis</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-123781"><a href="https://badgerherald.com/./opinion/">Opinion</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208541"><a href="https://badgerherald.com/topic/column/">Column</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208542"><a href="https://badgerherald.com/topic/letter-to-the-editor/">Letter to the Editor</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208566"><a href="https://badgerherald.com/topic/point-counterpoint/">Point-counterpoint</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-123782"><a href="https://badgerherald.com/./artsetc/">ArtsEtc</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208573"><a href="https://badgerherald.com/topic/art/">Art</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208570"><a href="https://badgerherald.com/topic/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208571"><a href="https://badgerherald.com/topic/film/">Film</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208574"><a href="https://badgerherald.com/topic/food/">Food</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208572"><a href="https://badgerherald.com/topic/hump-day/">Hump Day</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-topic menu-item-208575"><a href="https://badgerherald.com/topic/madtown-crier/">Madtown Crier</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170691"><a href="http://badgerherald.com/topic/visuals">Visuals</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-170087"><a href="https://badgerherald.com/./banter/">Banter</a></li>
</ul></div> </div>
<div class="right-rail rail">
<div class="menu-about-container"><ul id="menu-about-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170693"><a href="https://badgerherald.com/about/">About</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225106"><a href="https://badgerherald.com/masthead/spring-2018/">Staff</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-190879"><a href="http://advertise.badgerherald.com/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170692"><a href="https://badgerherald.com/newsletter/">Newsletter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222583"><a href="https://projects.propublica.org/graphics/hatecrimes-form">Report Bias/Hate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-203615"><a href="https://badgerherald.com/job-board/">Job Search</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191620"><a href="https://badgerherald.com/donate/">Donate</a></li>
</ul></div> </div>
<div class="clearfix"></div>
<div class="fine-print">
<p class="description">UW-Madison&#039;s Premier Independent Student Newspaper</p>
<p>All Content &copy; The Badger Herald, 1995 - 2018</p>
</div>
</div>
</div>
</div>
<script>

	/* Chartbeat */

	var _sf_async_config = {uid:45170,domain:'badgerherald.com',useCanonical:true};
		_sf_async_config.title ='Jeremy Zucker delivers energetic, feel-good performance in summer heat &middot; The Badger Herald';
		(function(){
			function loadChartbeat() {
			window._sf_endpt=(new Date()).getTime();
			var e = document.createElement('script');
			e.setAttribute('language', 'javascript');
			e.setAttribute('type', 'text/javascript');
			e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
			document.body.appendChild(e);
		}
	var oldonload = window.onload;
	window.onload = (typeof window.onload != 'function') ?
	loadChartbeat : function() { oldonload(); loadChartbeat(); };
	})();

</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2337436-1"></script>
<script>
		window.dataLayer = window.dataLayer || [];
		function gtag(){dataLayer.push(arguments);}
		gtag('js', new Date());
		gtag('config', 'UA-2337436-1');

		gtag('config', 'UA-2337436-1', {
			'custom_map': {
				'dimension1': 'days_old',
			}
		});
		gtag('event', 'load', { 'days_old': 1 });	</script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201828'></script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-content/themes/hexa/js/hexa.js?ver=1486186054'></script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-content/themes/exa/js/exa.js?ver=1519003624'></script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-includes/js/wp-embed.min.js?ver=4.8.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.8.7","language":""},"disqusIdentifier":"233238 https:\/\/badgerherald.com\/?p=233238","disqusShortname":"badgerherald","disqusTitle":"Jeremy Zucker delivers energetic, feel-good performance in summer heat","disqusUrl":"https:\/\/badgerherald.com\/artsetc\/2018\/07\/11\/jeremy-zucker-delivers-energetic-feel-good-performance-in-summer-heat\/","options":{"manualSync":"1"},"postId":"233238"};
/* ]]> */
</script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.8.7'></script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-content/plugins/DoubleClick-for-WordPress/js/jquery.dfp.min.js?ver=1.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dfw = {"networkCode":"8653162","mappings":{"mapping1":[{"browser":[0,1],"ad_sizes":[[300,340],[320,250]]},{"browser":[760,1],"ad_sizes":[[760,340],[970,250],[728,90]]},{"browser":[1060,1],"ad_sizes":[[1020,420],[970,250],[728,90],[970,50]]},{"browser":[1220,1],"ad_sizes":[[1180,420],[970,250],[728,90]]}],"mapping2":[{"browser":[0,1],"ad_sizes":[[300,250]]},{"browser":[1060,1],"ad_sizes":[[1,1]]}],"mapping3":[{"browser":[0,1],"ad_sizes":[[300,250]]},{"browser":[1060,1],"ad_sizes":[[1,1]]}],"mapping4":[{"browser":[0,1],"ad_sizes":[[1,1]]},{"browser":[1060,1],"ad_sizes":[[300,600],[300,250]]}],"mapping5":[{"browser":[0,1],"ad_sizes":[[1,1]]},{"browser":[1060,1],"ad_sizes":[[300,600],[300,250]]}],"mapping6":[{"browser":[0,1],"ad_sizes":[[1,1]]},{"browser":[1060,1],"ad_sizes":[[300,600],[300,250]]}]},"targeting":{"Page":["single"],"Category":["artsetc"],"Tag":["beach-island","electronica","glisten","jeremy-zucker","music","republic-records","summerfest","summerfest-2018"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-content/plugins/DoubleClick-for-WordPress/js/jquery.dfw.js?ver=1.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"badgerherald"};
/* ]]> */
</script>
<script type='text/javascript' src='https://badgerherald.com/wordpress/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.8.7'></script>
<script type='text/javascript'>
	jQuery(window).load(function () { jQuery('.dfw-unit:not(.dfw-lazy-load)').dfp({ 
		dfpID: '8653162',
		refreshExisting: false,
		collapseEmptyDivs: true,
		setTargeting: dfw.targeting,
		sizeMapping: dfw.mappings,
		afterEachAdLoaded: DFW.afterEachAdLoaded,
		beforeEachAdLoaded: DFW.beforeEachAdLoaded,
	}); }); 

</script>
<script type='text/javascript' src='https://stats.wp.com/e-201828.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.3',blog:'58277082',post:'233238',tz:'-5',srv:'badgerherald.com'} ]);
	_stq.push([ 'clickTrackerInit', '58277082', '233238' ]);
</script>
</body>
</html>